Command pf9ctl config set - how to send none as proxy

Hi Team,

I’m designing automation wherein; I’m trying to configure P9 on Ubuntu 18.04 via CLI using below commands by login into ubuntu server.

  1. sudo su -
  2. apt-get install ‘grub-efi*-’
  3. bash <(curl -sL https://pmkft-assets.s3-us-west-1.amazonaws.com/pf9ctl_setup)
  4. pf9ctl config set -u -e -p “” -t service -r RegionOne -l ‘’
    Here we need to know how to set “None” as proxy.

Regards,
Santosh

Hi @santoshreddy.spy, there was an internal issue filed for this. Let me check on the status of the fix and will let you know.

In the meantime can you confirm what is the version of pf9ctl you are using.

Hi Chaitanya,

We’re using Version 5.3.0-484.

Regards,
Santosh

Hi @santoshreddy.spy ,

The fix for letting you set the Proxy as None within the flag is being worked on in the ongoing sprint. Expect this to be in the CLI release which will be available towards the end of this month.

For reference v5.3.0-484 is the Platform9 version. The CLI version can be found by running
pf9ctl version. Currently the latest one is v1.8.

$ pf9ctl version
pf9ctl version: v1.8