Is Deploying the OVA to VSphere or VCenter supported?

I just signed up for a free account and I’m going through the tutorial.

When I go to deploy the OVA to an VSphere host, I get this message.
Line 31: Unsupported hardware family ‘virtualbox-2.2’.

Before I start editing the OVA to change the hardware type, I want to make sure I have the right file and that this is even supported. Is this supported? The file that I am using is Platform9_Ubuntu_20.04.ova

@mschlott yes, vSphere is fine and the OVA should work.

the OVA is just a simple VM with Ubuntu 20.04 with the Platform9 CLI already installed. So if you have a similar template feel free to use that.

Thanks. I got it working. I had to export the OVA using VMWare’s ovftool, then change the hardware version to “13”, then re-create the ova.

Do you happen to have the steps you used?

Sorry, I don’t have the exact steps, but here is the general idea.
Download ovftool from VMWare.
Use ovftool to convert the OVA file into vmx and vmdk files.
Edit the vmx file and change the following setting to 13.
virtualHW.version = “13”
Use ovftool to convert the vmx and vmdk back into an OVA file. This part was a little tricky because it complained about something in the config file and I had to use the -lax option to get it to run.

After creating the OVA, I was able to deploy the VM to Vcenter.

We were able to address this issue in this thread: Unable to get the OVA to work on free tier