Pf9ctl prep-node: Required OS Packages Check Fails on Ubuntu 20.04

I am failing to onboard an Ubuntu 20.04 node to my Platform9 infrastructure.

I did the following:

bash <(curl -sL https://pmkft-assets.s3-us-west-1.amazonaws.com/pf9ctl_setup)
pf9ctl config set
pf9ctl prep-node

Everything works fine, but step 3. fails with the following error

Required OS Packages Check - Some OS packages needed for the CLI not found. Packages not found and could not be installed ntp net-tools jq

I assume those packages have been retired/replaced in Ubuntu 20.04. I thought Ubuntu 20.04 is supported according to https://docs.platform9.com/kubernetes/kubernetes-cluster-pre-requisites

Hello @welker ,

Can you provide us complete pf9ctl logs to debug this issue further? You can also connect with our team on slack. Please use the below link to join the slack workspace.

Thanks,
Saurabh

Hi @ hedasaurabh,

thanks for you quick reply. I replied with the full log, which got stuck in the Akismet Spam Filter. I tried to contact the admins, but one can not message them directly.

Cheers,
Jan

Hey, @welker

Can you confirm if you are able to install these packages manually just to eliminate any permissions-based issues?

Thanks!

Hi, @welker we did confirm with the Engineering team that the next drop of the CLI should handle this case. For now, manually installing these packages should let you continue with the prep node. Let me know if you need any more help!

Hi @chaitanya

Installing the packages by hand revealed the Problem. I had a repository, which changed and that needed an confirmation in apt.

The prep-node worked like a charm after I fixed that.

Thanks for your help,
Jan