Unable to get the OVA to work on free tier

I have tried to install the OVA download on Vcentre 6.7

  1. I was getting the following error “The provided manifest file is invalid: Invalid OVF checksum algorithm: SHA1”

I then done the run the

ovftool.exe --shaAlgorithm=SHA256 /path/to/ova_file.ova /path/to/new/ova_file-SHA256.ova

  1. now i get the following error

Issues detected with selected template. Details: - -1:-1:VALUE_ILLEGAL: No supported hardware versions among [virtualbox-2.2]; supported: [vmx-04, vmx-07, vmx-08, vmx-09, vmx-10, vmx-11, vmx-12, vmx-13, vmx-14, vm

Hi @aqueel , currently there are some issues readily supporting the OVA on VMWare hypervisors. Please refer to this conversation: Is Deploying the OVA to VSphere or VCenter supported?

Alternatively, you can import the OVA on Oracle Virtualbox for a seamless experience.

Ok i will need to have a look

That post is very little detail how the problem was actually solved… NO instructions there

Hi Aqueel,

Apologies for the inconvenience, let me quickly test this out and provide a write-up to you.

We are also working on creating an OVA with native Vcenter support which should work out of the box. I’ll let @nikhil comment on the timelines.

Hi @aqueel, as a temporary workaround to this issue, follow the directions below.

NOTE: This is a temporary fix, and we are working internally to address this concern.

Run the following commands to convert the OVA to SHA256 if the downloaded file fails to upload with the following error

$ ovftool --shaAlgorithm=SHA256   Platform9_Ubuntu_20.04.ova Platform9_Ubuntu_20.04.ova-SHA256.ova

After this, you will see the following issue when deploying the OVA (This is expected behavior).

$ /Applications/VMware\ OVF\ Tool/ovftool --lax Platform9_Ubuntu_20.04.ova-SHA256.ova Platform9_Ubuntu_20.04.ova-SHA256.vmx
Opening OVA source: Platform9_Ubuntu_20.04.ova-SHA256.ova
The manifest validates
Opening VMX target: Platform9_Ubuntu_20.04.ova-SHA256.vmx
 - Line 31: Unsupported hardware family 'virtualbox-2.2'.
 - Line 89: OVF hardware element 'ResourceType' with instance ID '7': No support for the virtual hardware device type '35'.
Writing VMX file: Platform9_Ubuntu_20.04.ova-SHA256.vmx
Transfer Completed
Completed successfully

Next, open the vmx file in vim and modify line 6 in the file:

$ vim Platform9_Ubuntu_20.04.ova-SHA256.vmx

LINE 6: virtualhw.version = “18” —> Change this value FROM 18 to 13

Then, convert the vmx file back to an OVA again.

$ /Applications/VMware\ OVF\ Tool/ovftool --lax Platform9_Ubuntu_20.04.ova-SHA256.vmx Platform9_Ubuntu_20.04_hw13.ova-SHA256.ova

Now you should be able to deploy the OVA file without any errors.

Special thanks to @chaitanya for doing all the heavy lifting on this issue! :man_superhero:

Hi @aqueel,

The image you uploaded only shows the top of the program:

Can you re-upload a screenshot of the error you are seeing or add the error message you are getting?

Dude you a genius - It worked!!


Please let us know if you run into any further issues with this OVA. I can also state that we have a VMware compatible OVA coming very soon.

We truly appreciate your feedback as it helps us pinpoint areas of growth we can address :smiley:

@aqueel just one more point to note. If the VM doesn’t launch currently you might want to try to edit the virtualhw.version according to VMware Knowledge Base depending on your Vcenter version.

13 should work for ESXi 6.5 and later according to Hardware Features Available with Virtual Machine Compatibility Settings but just wanted to put it out there.